Author Topic: Fuel pump issues  (Read 198 times)

Offline bigdaddynandez

  • Paid Members
  • Trail Queen
  • ***
  • Posts: 64
Fuel pump issues
« on: June 08, 2017, 11:52:01 PM »
For those that weren't at the meeting this week, I'm trying to get my truck back on the trails but the fuel pump isn't turning on. I replaced all the old wire with new ones and cleaned the ground, checked the fuses and it still wouldn't start. I then wired the positive directly to battery and it still isn't turning on. Does that mean the pump itself is no good? Idk what else to do to trouble shoot but I'd really like to get this fixed asap so I can make it out to sawmill next weekend.

Offline calvynandhobbs

  • BOD
  • Trail Master
  • *****
  • Posts: 2946
Re: Fuel pump issues
« Reply #1 on: June 09, 2017, 03:38:27 AM »
I don't know wiring very well, but it sounds like you directly applied power to the battery and the pump still isn't working so to me that sounds like a bad fuel pump.
1994 YJ on 35s

Offline Mr Rock

  • Administrator
  • Trail Master
  • ***
  • Posts: 1508
Re: Fuel pump issues
« Reply #2 on: June 09, 2017, 03:53:15 AM »
I would double check your wiring, if it worked before you rewired it then most likely your wiring is the culprit. could be just  a bad connection....
'89, 4.2, NUTTERED, Team Rush, 4" Lift, 1" BL, 1" MML & HD shackles , Flat Belly Skid, SYE, 36 x 13.50s
XRC8, 150w KC's, Herculined, Tauras Elec Fan, Dual Batteries, Aussie in front, 8.8, TJ flares & Spool in rear, topless all of the time!

Offline DirtyJeep92

  • VP
  • Rock Crawler
  • *****
  • Posts: 416
  • 96 XJ HP44/9" 37s chopped caged.
Re: Fuel pump issues
« Reply #3 on: June 09, 2017, 06:56:30 PM »
Is it just a power and ground or multiple wires? If you have the power directly to Bayer and have a good ground then the pump is shot
ED 2

Offline bigdaddynandez

  • Paid Members
  • Trail Queen
  • ***
  • Posts: 64
Re: Fuel pump issues
« Reply #4 on: June 09, 2017, 07:37:54 PM »
Is it just a power and ground or multiple wires? If you have the power directly to Bayer and have a good ground then the pump is shot
Yeah it's just those two

Offline Swindle

  • Paid Members
  • Trail Passenger
  • ***
  • Posts: 24
Re: Fuel pump issues
« Reply #5 on: June 14, 2017, 02:57:30 AM »
Is there a relay in the circuit? I had a similar issue and it turned out to be the relay.

Offline bigdaddynandez

  • Paid Members
  • Trail Queen
  • ***
  • Posts: 64
Re: Fuel pump issues
« Reply #6 on: June 14, 2017, 04:10:00 AM »
There is no relay. I called the company they said it could be rust build up inside from not running it, so I'm charging my battery tonight and trying again tomorrow. They recommended fully charging it and then run it again while on a charger and that should break up the rust inside

Offline DirtyJeep92

  • VP
  • Rock Crawler
  • *****
  • Posts: 416
  • 96 XJ HP44/9" 37s chopped caged.
Re: Fuel pump issues
« Reply #7 on: June 20, 2017, 12:00:48 AM »
Is the pump internal or external. If external. Try taping on it or put some air to it might be clogged
ED 2

Offline bigdaddynandez

  • Paid Members
  • Trail Queen
  • ***
  • Posts: 64
Re: Fuel pump issues
« Reply #8 on: June 20, 2017, 01:02:01 AM »
Got the pump running! Truck is good to go, issue was the battery and rust inside the pump itself